Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 61

Thread: Smite low fps and stuttering fix

  1. #1
    Senior Member Honoured Adr1anP3laj's Avatar
    Join Date
    Apr 2015
    Location
    Behind my computer
    Posts
    574
    5
    Level completed: 4%, Points required for next Level: 769
    Achievements:
    Full Profile! Repped! Third Class 1000 Experience Points Tagger Second Class 3 months registered
    Rep Power
    5

    Smite low fps and stuttering fix

    ***UPDATE 11.7.2015

    Hey guys, I decided to make my first forum post just to share with you all my fix for the very problematic low fps or in my case fps drops in smite. I didn't find anything like this on the web so here it is. I don't know how many of you noticed, but if you change your world detail settings from medium to low it's a 100fps difference.. atleast for me it went from 50fps to 150 or more. Hi rez developers you absolute studs..

    But ofcourse I didn't wanna play with low settings as it looked horrible without the fog and all the major visuals of the game. So I was wondering what could possibly hog so much fps, at first I thought it was the fog, since the low world details disables the fog completly.. but after some googling I found out it was actually the grass/foilage. Escpecially the foilage in the Siege map, that's where my fps would drop massively.
    So I tried to find a fix that would disable all the extra bushes, plants and leaves whilst still keeping the fog and all the other visuals to the max ( since those didn't really effect my fps ).

    Anyways, to do that I had to change some variables in the game's .ini file, the one that stores all the game's or should i say unreal engine 3 settings.

    The file can be found here: C:\Users\[your username]\Documents\My Games\Smite\BattleGame\Config

    The file you wanna open is BattleSystemSettings.ini, now I suggest backing up the entire Config folder just in case you would want to revert the settings back.
    Open the file up and press ctrl+F, type in DetailMode= and start searching, change the variable to 0 for every line you find, there should be multiple.
    Then press up ctrl+F again and type in bAllowFog= and change all the lines you find to True.
    If you want you can also enable motion blur, it wont make your fps better but I don't think it makes it worse either. I personally think it looks good in game. To do that just ctrl+F and find MotionBlur= and change it from False to True.

    ***For this fix to work with the new arena map, ctrl+F and search for SpeedTreeWind= and change it to False.

    That should be it, all the extra foilage will now be gone, but all the good visuals like the model render distance and fog will stay on maximum ( ofcourse make sure you put the world detail setting to what you want before you do this guide, I keep mine on maximum ). When you go ingame you'll now see the world detail is set as "custom". Don't change this as it will revert what you just did after a restart of the game.

    I also highly advise you set particle detail to low, this will keep you from dropping fps and stuttering in big team fights.

    Here you can see the fps difference in the top right corner and also the removal of foilage.
    Before: s1.postimg.org/7ap9gc727/image.jpg
    After: s1.postimg.org/campoacov/image.jpg

    -[Frame cap and Vsync]-

    Now head back into the config folder and open up BattleEngine.ini, ctrl+F and search for MaxSmoothedFrameRate= ..it should say 150.000000, that means the game is capped at 150 fps, we want to cap it at 60 so just change the numbers to 60.000000. I guess you could skip this step if you already use a software for capping frames such as Msi Afterburner's RivaTuner. But I still think the game's inbuilt capping system works better.. up to you. Capping the fps gets rid of the mouse input lag when using Vsync. On that point, keep the game's Vsync ON to prevent screen tearing.

    I hope this guide helped atleast some of you

    -Another thing to keep in mind is the alt+tabing in this game. If you alt+tab out and in the game sometimes your fps will lower itself by half. I think it's because the game opens up with integrated graphics instead of your GPU. To fix this make sure you have Aero theme enabled, this prevents the switching of cpu and gpu since the Aero makes the desktop run on your gpu.
    Last edited by Adr1anP3laj; 07-12-2015 at 02:23 PM.

  2. #2
    FACEIT Prestigious Kaostic's Avatar
    Join Date
    Mar 2014
    Location
    London, UK
    Posts
    3,303
    42
    Level completed: 72%, Points required for next Level: 1,222
    Achievements:
    Tagger Third Class Reputation Distributor Repped! First Class Arm of the Law! Discussion Ender
    Rep Power
    50
    Moved to PC General Discussion.
    Community Coordinator for FACEIT | @Kaostic

  3. #3
    Senior Member Chosen Boatmurdered's Avatar
    Join Date
    Apr 2014
    Posts
    2,077
    13
    Level completed: 6%, Points required for next Level: 1,232
    Achievements:
    Repped! First Class Veteran 10000 Experience Points
    Rep Power
    11
    Quote Originally Posted by HiRezKaostic View Post
    Moved to PC General Discussion.
    Did...did you just get hired? For reeeealzies?
    I made this god idea tell me how bad it is, yo!
    http://forums.smitegame.com/showthre...ess-of-Disease


    Finally I make mediocre youtube videos of me playing Smite...mostly of Vulcan.....cough
    http://www.youtube.com/user/MrNinjaBurger

  4. #4
    Super Moderator Godlike RainbowSplat's Avatar
    Join Date
    Aug 2014
    Location
    Somewhere lost in Time
    Posts
    18,567
    33
    Level completed: 73%, Points required for next Level: 933
    Achievements:
    Tagger Second Class Reputation Distributor Repped! First Class Repped! Second Class Full Profile!
    Awards:
    Discussion Ender
    Rep Power
    50
    i dont see "'visual effects"" in options what do u mean exactly by it? also why cap the fps to 60 from 150?
    Last edited by RainbowSplat; 04-02-2015 at 12:58 PM.
    *Disclaimer: I am a volunteer moderator. I work on best judgement and do not speak on behalf of Hi-Rez Studios.*

  5. #5
    Senior Member Honoured Adr1anP3laj's Avatar
    Join Date
    Apr 2015
    Location
    Behind my computer
    Posts
    574
    5
    Level completed: 4%, Points required for next Level: 769
    Achievements:
    Full Profile! Repped! Third Class 1000 Experience Points Tagger Second Class 3 months registered
    Rep Power
    5
    Quote Originally Posted by RainbowSplat View Post
    i dont see "'visual effects"" in options what do u mean exactly by it? also why cap the fps to 60 from 150?
    Sorry I meant effect quality, I fixed it so there's no confusion. You wanna cap the fps to 60 or 58 to minimize input lag and stuttering. You especially need to do this if you're using any kind of vsync. And in Smite the screen tears are crazy without vsync, so I suggesting having it on.

    Basically having vsync on with triple buffering enabled and a capped framerate will make your game run smooth as butter.

    On another point, the human eye can't see the difference between 60 and 150 fps, so there really is no need for a higher number. Plus you're hogging your PC with generating more heat and using more ram.

    This might work differently if you have a 120hz monitor, mine is 60hz so capping the frames to 60 works great.

  6. #6
    Super Moderator Godlike RainbowSplat's Avatar
    Join Date
    Aug 2014
    Location
    Somewhere lost in Time
    Posts
    18,567
    33
    Level completed: 73%, Points required for next Level: 933
    Achievements:
    Tagger Second Class Reputation Distributor Repped! First Class Repped! Second Class Full Profile!
    Awards:
    Discussion Ender
    Rep Power
    50
    Quote Originally Posted by Adr1anP3laj View Post
    Sorry I meant effect quality, I fixed it so there's no confusion. You wanna cap the fps to 60 or 58 to minimize input lag and stuttering. You especially need to do this if you're using any kind of vsync. And in Smite the screen tears are crazy without vsync, so I suggesting having it on.

    Basically having vsync on with triple buffering enabled and a capped framerate will make your game run smooth as butter.

    On another point, the human eye can't see the difference between 60 and 150 fps, so there really is no need for a higher number. Plus you're hogging your PC with generating more heat and using more ram.

    This might work differently if you have a 120hz monitor, mine is 60hz so capping the frames to 60 works great.
    i dont have 120hz but 60 like you but u said u need to turn off v-sync ingame options but turn it on in these settings i have ""amd catalyst control center"" but i cant seem to find what exactly i need turn there on and what not maby u could help me here



    copy img url and open it in new tab the pic will be bigger and easier to see

    also i still dont see effect quality lol...all i see is

    world detail

    texture detail

    shadow detail

    shader quality

    practice detail

    anti aliasing
    Last edited by RainbowSplat; 04-02-2015 at 01:47 PM.
    *Disclaimer: I am a volunteer moderator. I work on best judgement and do not speak on behalf of Hi-Rez Studios.*

  7. #7
    Senior Member Honoured Adr1anP3laj's Avatar
    Join Date
    Apr 2015
    Location
    Behind my computer
    Posts
    574
    5
    Level completed: 4%, Points required for next Level: 769
    Achievements:
    Full Profile! Repped! Third Class 1000 Experience Points Tagger Second Class 3 months registered
    Rep Power
    5
    Quote Originally Posted by RainbowSplat View Post
    i dont have 120hz but 60 like you but u said u need to turn off v-sync ingame options but turn it on in these settings i have ""amd catalyst control center"" but i cant seem to find what exactly i need turn there on and what not maby u could help me here
    Hmm I'm not familiar with amd cards since I have nvidia myself, so I don't know if the same settings apply to you. But from looking at the screenshot I think you need to go into application settings, find smite.exe or maybe add it yourself, and then customize the settings. If you can't find it just leave the game's vsync on and do the rest of the guide, it works fine. Like I said, I'm not familiar with AMD cards so maybe your settings overall are a bit different.

    As for the effects, I'm sorry again.. I must have hit my head and saw the settings wrong What I meant was particle detail. Just set that to low.

  8. #8
    Super Moderator Godlike RainbowSplat's Avatar
    Join Date
    Aug 2014
    Location
    Somewhere lost in Time
    Posts
    18,567
    33
    Level completed: 73%, Points required for next Level: 933
    Achievements:
    Tagger Second Class Reputation Distributor Repped! First Class Repped! Second Class Full Profile!
    Awards:
    Discussion Ender
    Rep Power
    50
    hmm okay il leave then v-sync on ingame and in that amd catalyst settings i guess i will leave ""OpenGL tripple buffering"" also on
    *Disclaimer: I am a volunteer moderator. I work on best judgement and do not speak on behalf of Hi-Rez Studios.*

  9. #9
    Senior Member Infamous Disquieted1's Avatar
    Join Date
    Oct 2014
    Location
    I found my loli sidekick
    Posts
    5,492
    16
    Level completed: 22%, Points required for next Level: 1,092
    Achievements:
    3 months registered 10000 Experience Points Full Profile! Repped! Second Class Repped! Third Class
    Rep Power
    12
    Or, you can always buy an Alienware. *exasperated, flemful cough*
    Smite is an online multiplayer game. You can't have immediate gratification simply by starting the game. The ground is even. There's another player on the other side. You are not entitled to having everything favoring you at every time. If you don't like it, by all means, go back to the 1-shot-kills-all Aliens: Colonial Marines singleplayer.

  10. #10
    Senior Member Honoured Adr1anP3laj's Avatar
    Join Date
    Apr 2015
    Location
    Behind my computer
    Posts
    574
    5
    Level completed: 4%, Points required for next Level: 769
    Achievements:
    Full Profile! Repped! Third Class 1000 Experience Points Tagger Second Class 3 months registered
    Rep Power
    5
    Quote Originally Posted by RainbowSplat View Post
    hmm okay il leave then v-sync on ingame and in that amd catalyst settings i guess i will leave ""OpenGL tripple buffering"" also on
    Yeah that should work just fine. If you did everything right your fps ingame should be at a constant 60.

    Quote Originally Posted by Disquieted1 View Post
    Or, you can always buy an Alienware. *exasperated, flemful cough*
    My pc specs are good, it's just that the game engine Smite runs on is old and Hi rez developers made sure you have unnecessary settings turned ON I've read online even people with cards like gtx780 are having trouble with fps in smite.
    Last edited by Adr1anP3laj; 04-02-2015 at 02:21 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •