Results 1 to 1 of 1

Thread: I can't launch Smite after the Kumbhakarna patch

  1. #1
    New Member Cupidhead Skiether's Avatar
    Join Date
    Apr 2014
    Posts
    1
    3
    Level completed: 23%, Points required for next Level: 545
    Achievements:
    Tagger Third Class 1 year registered 1000 Experience Points
    Rep Power
    0

    Unhappy I can't launch Smite after the Kumbhakarna patch

    Before the patch I could launch the game and play normally, now I can't. When I try to launch Smite nothing happens. HirezGameNotifier appears in my processes, and after 5 or 6 seconds it disappears. I've already tried reinstalling the game and using the Validate/Repair thing but neither of them have changed anything.

    Any help would be greatly appreciated.


    SOLVED: I don't know why, but Windows firewall was blocking smite, all I had to do was allow it through.
    Last edited by Skiether; 04-19-2014 at 06:28 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •