View Poll Results: Do you think Sobek clipped through Sol?

Voters
1. You may not vote on this poll
  • Yes

    1 100.00%
  • No

    0 0%
Results 1 to 3 of 3

Thread: Not sure if I clipped through Sol

  1. #1
    Junior Member Senior Cupidhead Vdrift's Avatar
    Join Date
    May 2018
    Location
    Puerto Rico
    Posts
    53
    1
    Level completed: 54%, Points required for next Level: 186
    Achievements:
    Full Profile! 100 Experience Points 7 days registered
    Rep Power
    1

    Question Not sure if I clipped through Sol

    So I was playing a game of Clash as Sobek and you know, it's fine. I finally assisted someone for a kill instead of covering the minion wave some didn't see. But then, I noticed during my attempt to give a 4th kill, I just notice this happen.

    https://twitter.com/RockyStarstrike/...99072316928000



    Not sure if I clipped through Sol on that last bit, but it did bother me a little bit. Maybe it was a one time mistake or she moved to the side and luckily dodged it. I don't know. What do you guys think? I ain't considering this a bug still, unless someone who knows the game better than me does. That's all I can say.

  2. #2
    Senior Member Chosen RandomToon's Avatar
    Join Date
    Nov 2015
    Posts
    1,117
    7
    Level completed: 11%, Points required for next Level: 804
    Achievements:
    1000 Experience Points Repped! Third Class 1 year registered
    Rep Power
    4
    Looks like lag. You definitely should have plucked her. She didn't have her iframes from her 3, didn't use beads, and she didn't have CC immunity left over from her ult (all of those would have resulted in hitting her, stopping, and seeing an "immune" pop up). Unless her 1 suddenly gives iframes, looks like you got screwed.
    Remember The Manticore

  3. #3
    Junior Member Senior Cupidhead Vdrift's Avatar
    Join Date
    May 2018
    Location
    Puerto Rico
    Posts
    53
    1
    Level completed: 54%, Points required for next Level: 186
    Achievements:
    Full Profile! 100 Experience Points 7 days registered
    Rep Power
    1
    You could be right. I didn't see anything pop up. And I just went through. I suppose lag could be the only possible solution. I'll wait and see what others think as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •