Results 1 to 4 of 4

Thread: LAG-BUG sort of ?? (BLOCK: Can't play SMITE because of it)

  1. #1
    Junior Member Cupidhead Akfiz's Avatar
    Join Date
    Jun 2016
    Posts
    14
    4
    Level completed: 83%, Points required for next Level: 121
    Achievements:
    1000 Experience Points Veteran
    Rep Power
    0

    Question LAG-BUG sort of ?? (BLOCK: Can't play SMITE because of it)

    I don't really know what's going on, my internet connection works great, except in Smite.

    And my system requirements are good, I even played the game in safe mode, still the same ressult.


    So everything was fine until 2 days ago I started Smite and I noticed the loading screen would take a lot longer than usual. Then in game I pressed "play" and when I tried to press accept I noticed the button wouldn't work.

    Then I tried again, and again, and again. Same ressult, the accept button wouldn't work.

    I went to my referals and I noticed none of them were there, I went to my profile and I noticed my profile would take a lot to load.


    Then I restarted the game and pressed play again, same thing, the accept button wouldn't work.

    Then I restarted a game and asked a friend to play with me.

    He received the "accept box" much earlier than me, I think I received the accept box like 30 minutes later and I think the reason the "accept" button wouldn't work is becasue the box was actually gone, it was just a delay or bad connecton.

    So basically I received the "accept" button much later than the other 9 players and by the time I grahpically received the accept box in the server the box was already gone and I didn't press accept. Sort of a delay or lag bug ?

    I tried again, same ressult. I restarted the game and tried again same ressult.


    Today I tried again, the first time it worked, but then after the game I noticed my goodwill dropped to 6%.. it was kinda strange of why I got reported, I had the best score in my team and I didn't insulted anyone, my whole chat was something like "back" or "play def ok ?". Then it hit me, it was because of those times the accept button didn't worked.

    After that first game I tried to play another game, but then again the "accept" button wouldn't work.

    This was the first time this bug happened, the bug just started happening suddenly. I did not had this problem before. I'm playing SMITE through Steam.

    I lost a lot of goodwill with this bug, not to mention I'm unable to play Smite now.

  2. #2
    New Member Cupidhead Mishrito's Avatar
    Join Date
    Feb 2015
    Posts
    7
    2
    Level completed: 70%, Points required for next Level: 153
    Achievements:
    1 year registered 1000 Experience Points
    Rep Power
    0
    This happens to me too and only when my connection is kinda slow/not good. First of all when I join a queue, the green play button doesn't change into the red timer. So even though I'm actually in a queue, the client doesn't tell me that. Then some time later it does change. At some point the queue pops but I'm not notified and hence unable to accept the queue. When it does show up, I can press the accept button but nothing happens (since it is actually already gone), and can see everyone else accept one by one. The timer goes to 0:00 and stays that way for some time, and then all of a sudden I'm told that I dodged and I have a 2 min deserter. Sometimes the delay between the actual queue popping and it showing up on my screen is so much that by the time all of this happens, I've already served my 2 min deserter lmao. Another observation is that whenever this happens, going to the profile tab doesn't show anything (name, mastery, goodwill fields are all empty, accolades are empty, worshippers doesn't show anything, basically everything is empty). Now this is what happens when my connection is slow.

    When it is nether slow nor fast, sometimes the queue pops in time for me to be able to accept it, but doesn't immediately take me to god selection. Then eventually at some point I do enter god selection, but I can't actually select a god (because all of this has already happened), and I can see everyone else select their own choices in the order in which they selected and even at the actual time when they selected. So the timer sometimes counts down to zero and stays that way for some time and then i get back to the home screen with a 30 min deserter or sometimes it stops midway and sends me to home screen. It seems like the client shows everything with a time phase difference. Sometimes I'm lucky enough that this difference is not larger than the entire duration of god selection (which is something like 90 seconds i guess?) for me to be able to select a god (even then I don't actually see my own selection immediately but see everything as it happened sometime ago and then finally see my own selection), and therefore enter the game.

    Everything in the previous paragraph happens way more often when I'm in a party, whereas the first case happens both when I'm solo queuing and in a party; the problem being that this happens so much that I haven't been able to play in a party for more than 1 or 2 matches without this happening eventually; after which ofc I can't play because I then have a deserter.

    None of this happens when my connection is super fast.

    Now I know one'd say "Get better internet and stop complaining to the game devs", but for various reasons I'm stuck with this connection (among them being that this is the only ISP available where I live). Also I'm just gonna say I've played so many multiplayer games over the years on the same connection and none have frustrated me nearly as much as smite has. I understand that if the devs think this isn't an issue important enough to address or not easy enough to simply "fix", then that's that. But for what it's worth, I'm just gonna say that as a customer who has spent a significant amount of time and money on this game, these problems have made my experience less and less enjoyable, which is sad given how amazing the core game itself is, and which is the reason I keep coming back every time.
    Last edited by Mishrito; 10-08-2016 at 06:57 AM.

  3. #3
    New Member Cupidhead Mishrito's Avatar
    Join Date
    Feb 2015
    Posts
    7
    2
    Level completed: 70%, Points required for next Level: 153
    Achievements:
    1 year registered 1000 Experience Points
    Rep Power
    0
    And of course there aren't any replies, or any sort of acknowledgement. Look, I don't want to be that guy, but it's not like the forums are flooded with hundreds of bug reports everyday anyway. What's the point of me spending so much time trying to give all the details of an issue when it's just going to get ignored? Seems like a complete waste of time.

  4. #4
    Banned Chosen IceQueenLaSaia's Avatar
    Join Date
    Jun 2016
    Location
    Germany
    Posts
    1,249
    5
    Level completed: 13%, Points required for next Level: 702
    Achievements:
    3 months registered Full Profile! 1000 Experience Points
    Rep Power
    0
    posted bugs are not ignored, but devs only reply when they need more information from you or clarifying from what i've seen. they may be working on it but issues like this aren't always easy to solve.

    However, are you sure you're not having much internet traffic/downloads and queueing for the right server? when i queue for sea cause of my partner it takes 3sec for me to receive the data and i have 240 ping in game because of that, which isn't a bug.

    just trying to help i don't work for hi-rez

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •